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SAP MDMS TRAINING COURSE 

Welcome 

 

Thank you for attending this training for the 

Meter to Cash Application Implementation 

Project 
 

Name of Course: SAP Meter Data Management System 

(MDMS) 
 

Contents of this training are protected by copyright and cannot 

be reproduced in any manner. 

 

 

Housekeeping 

 

 Start and End Times 

 Facilities 

 Lunch and Breaks 

 Special Needs 

 Rules for Cell phone, Laptops, etc. 

 Group discussions and participation are encouraged 

 Health and Safety 

 Practical Exercises 

 

 

Please Introduce Yourself 
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 Your Name 

 Your Department and Division 

 Your Role 

 Your personal objective for the course 

 Your biggest challenge and expectation 

 What do you find most satisfying working in your division 

 

 

Course Objectives 

 

 Provide stakeholders with understanding where Zimele MDMS 

fits into the Landscape. 

 Provide stakeholders with understanding to set up the meter, 

and an understanding of what more technical training may 

be needed based on specific infrastructure situations. 

 Add more logins under the Administrator Role. 

 Add restricted Roles and Logins for colleagues. 

 Add separate Organizations, Roles and Logins for your 

Customers. 

 Test and support a login you’ve created. 

 Provide stakeholders with understanding to set up MDMS 

entities. 

 Do real time reading from SAP 

 Switch on and switch off from SAP 

 Send STS code from SAP 

 Knowing how to analyze the SOAP logs. 

 Knowing how to analyze the Meter Read Requests. 
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 Understanding and troubleshooting the Meter Model as 

mirrored from SAP to MDMS. 

 Understand when Meter Reading Requests are honored. 

 

Course Outcomes 

 

 Understanding where Zimele MDMS fits into the Landscape. 

Basic understanding. 

 Configure a new meter on Zimele MDMS for Automatic 

Reading. 

 Configure commissioning and reading parameters correctly 

per meter. 

 Kick off a Read-In attempt and verify it via a Web Browser. 

 Do basic troubleshooting on meters not coming in. 

 Ability to customize Zimele MDMS for different Roles and 

Organizations. 

 Add an MDMS entity. 

 Set up an MDMS entity SOAP connection to SAP in both 

directions. 

 Set up MDMS Events 

 Set up Summated Maximum Demand relationships for SAP 

billing. 
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AGENDA 
Glossary  

Module 1: Course 131 Admin Role: Configuring Accounts and Permissions  

1.1  Adding a Login Account 

1.2  Add Organisational Role  

1.3  Add An Organization 

Module 2:  Course 102 Engineer Role: Adding and Calling in a Meter on 

Zimele MDMS 

2.1 Adding a Meter 

2.2 Testing Communication Tools – Communication Monitor 

2.3 Commissioning – Edit Meter Details 

 

Module 3:  Course 160 Engineer Role: Meter Data Unification and 

Synchronisation SAP to Zimele MDMS Interface 

3.1 How to add an MDMS entity on Zimele MDMS 

3.2 How to configure the SOAP endpoints on the MDMS 

3.3 How to configure MDMS Events 

3.4 How to setup MD Summation 

 

Module 4:  Course 161 Engineer Role: MDMS Troubleshooting 

4.1 How to analyse SOAP logs 

4.2 How to analyse Meter Read Requests 

4.3 How to see why Meter Readings are not updating 

4.4 How to see why Meter Readings are wrong 
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GLOSSARY 
 

AMI Advanced Metering Infrastructure 

AMR Advanced Meter Reading 

AMS Advanced Meter Systems 

CT Current Transformer 

EHP4 Enhancement Pack 4 

IS-U Industry Solutions Utilities 

MDUS Meter Data Unification and Synchronisation 

MDMS Meter Data Management System 

PI Process Integration 

PO Process Orchestration 

SOAP Simple Object Access Protocol 

TOU Time of Use 

VT Voltage Transformer 

WSDL Web Services Description Language 
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MODULE 1: COURSE 131 ADMIN ROLE: 

CONFIGURING ACCOUNTS AND PERMISSIONS  

 

Once you are done with this course, you should be able to: 

• Add more Logins under the Administrator Role 

• Add restricted Roles and Logins for colleagues 

• Add separate Organizations, Roles and Logins for your customers 

• Test and support a Login you've created 

 

Module 1.1: Adding a Login Account 

 

• The basic building blocks in plug and play Scada are called Entities 

• An entity can be anything from a Meter to a Login Account, a Role, an 

Organization, a Tariff, a TOU Calendar etc. 

• To add any kind of Entity to the system, click the Add New button at 

the bottom of the overview screen. 

• Alternatively, go to the File menu (next to Home), and click on New 
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Step 1: Login 

 
 

 
 

• To start adding Entities on the system, the first step is to log in: 

• Go to the log in page at: https://zimeletech.pnpscada.com (our 

training server) 

 

  

https://zimeletech.pnpscada.com/
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Step 2: Click on the add new button   
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Step 3: Select User Admin 
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Step 4: Select a Login Account  
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Step 5: On the dropdown list, choose a role and then press on the next button 
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• Every User Login Account belongs to a Role 

• You should have at least one Administrator Role attached to your own 

Login 

 

 
Step 6: Add Login 
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• Fill out the relevant fields 

• You must specify the entries with a red asterisk (*) next to them 
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• You can always edit the other options later under 

Edit->Login, or that user can set up his own info under 

Edit->My Info 
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• Press Update button to update/change your details. 
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1.1.1  Exercise 1: Module 1 Add an Administrator Login to your 

Organization. 

 
Call the Trainer if you have any questions, and when you're done. 
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1.2  Module 1.2: Add Organizational Role 

Step 1: Click on the add new button   
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Step 2: Select User Admin 
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Step 3: Select Organisational Role 
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Step 4: On the drop-down list, select organisational role and then press 

Next button    
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• Every Role is in an organization 

• You should have at least one Organization attached to your own Login 
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Step 5: Add Role 

 

 

 
• Fill out the relevant fields 

• The only important one at this stage is the Role Description 

• The other options are best edited later through specialized screens 

• Press Finish to add the new Role 
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Step 6: On the edit menu, select Role 

 

 
 

• Your Role is now added, and we're ready to configure it further.  

• You can press the Home link from anywhere on the site to return to the 

overview screen. 
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Step 7: Select from list to browse the roles then click on Open button
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Step 8: Editing the Role  

 

 
 

• On this screen you may edit the Role Description, set the Start Page for 

the Role (on login), and set the Restrictions 

• There are 3 kinds of restrictions: 

 Which Entities can be seen 

 Enabled Functionalities (screens that can be used) 

 What kind of new entities may be added by this Role 

• Click on the Update button  when done 
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1.2.1 Exercise1.2: Module 1: Add a Role that cannot 

access the Administrator Role. 

 
• Add a Login on that Role. With the new Login selected, go to 

Tools->Zoom to Login. Click the Zoom In button. 

You should now 'see' what that login would see if they logged-in. 

• Try to view the Administrator Role under Home from the new Login. 

• Now try to view the Administrator Role under Home from your old login. 

 

• Call the Trainer if you have any questions, and when you're done. 
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1.3 Module 1.3: Add an Organization 

Step 1: Click on the add new button   
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Step 2: Select User Admin 
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Step 3: Select Organization 
 

 

 

 

 

• Reasons to add a new Organization as administrated by yourself, is for 

the sake of giving your customers their own logins with: 

 Their own banner image on top 

 Their own sub-domain 

 Their own unique login space (so that their customer logins could 

potentially be duplicated with another organization on another 

sub-domain without clashing, e.g. SHOP01 in two different 

Shopping Centers) 
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Step 4: Add the Organization details 

 
 

 

 

• Fill out all the relevant fields 

• Press the Finish button  to add the new Organization 
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• You can edit the Organization setting later from 

Edit->Organization 
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1.3.1  Exercise 1.3: Module 1 - Edit your organization’s properties 

 
Call the Trainer if you have any questions, and when you're done. 
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2 MODULE 2: COURSE 102 - ENGINEER ROLE: ADDING AND 

CALLING IN A METER ON ZIMELE MDMS 

 
Once you are done with this Course, you should be able to: 

 Configure a new meter on Zimele MDMS for Automatic Reading 

 Configure commissioning and reading parameters correctly per 

meter 

 Kick off a Read-in attempt and verify it via a Web Browser or a 

J2ME cell phone application 

 Do basic troubleshooting on meters not coming in 

 

2.1 MODULE 1: Adding a Meter 

 The basic building blocks in Zimele MDMS are called Entities 

 An Entity can be anything from a Modem to a Meter to an 

Etherpad; a SIM Card, a Login Account, a Role, an 

Organization, a Tariff, a Time of Use Calendar etc. 

 To add any kind of Entity to the system, click the Add New 

button at the bottom of the overview screen 

 Alternatively, go to the File menu (next to Home), and click on 

New 
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Step 1: Login 

 

 
 

 To start adding Entities on the system, the first step is to log in: 

 Go to the log in page at: https://zimeletech.pnpscada.com 

(our training server) 

 

  

https://zimeletech.pnpscada.com/
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Step 2: Click on the add new button   
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Step 3: Select a Meter 
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Step 4: Select type (kind) of a Meter you want to add 

 

 
 

 Meters that we currently support include many meters from 

Elster, Landis&Gyr, Enermax, EDMI meters etc. 

 Water Meters can be added as Pulse Meters 
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Step 5: On the dropdown list, choose a communication device and then 

press on the next button  
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Step 6: Add Meter details and once done click on finish button 
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Step 7: Click on Link this entity to limited roles 

 

 
 

 

 

  



 

Proprietary & Confidential   |   Page 46 

Step 8: Select on a Communication Device (Dependencies) 
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 Depending on the Meter type you selected, you may now have 

to set up various Entity Dependencies 

 Most Meters rely on a Communication Device to function, for 

example a Modem or an Etherpad 

 Pulse Meters depend on a Pulse Counting Device. 

More on that in the courses: 

Installation of Wavenis Meters on Zimele MDMS and: 

Installation and Maintenance of Pulse Meters on Zimele MDMS 

 If you have already added the Communication device before, 

you can select it from the list 

 Alternatively, you can click on Add New button to 

add a new Communication device Entity 
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Step 9: Adding more Communication Devices (Dependencies) 
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 Fill out all the dependency screens as you encounter them. As 

you step through them, the needed Entities will be added and 

filled into the previous screens 

 When adding SIM cards, you need to enter the full SIM card 

number (typically 19 to 21 digits long), as well as the cell phone 

number (international notation please) 
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 When adding Etherpads, you typically need the TCP port, and 

possibly the IP  
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Step 10: On the Overview screen 

 

 
 

 
 

 Your Meter is now added, and we're ready to communicate 

with it.  

 Select your meter on the overview screen by drilling down on 

the categories and selecting it 
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 You will be presented with the Object Dependency view. You 

can select the entities to the left and right of the selected Entity 

to navigate the Entity Dependency Tree 
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2.1.1 Exercise 2.1: Module 2  

 
As part of this course, you have been issued a Meter and 

Communication Device, together with all the communication 

parameters you need to configure the device on Zimele MDMS. 

    

Now add the Meter and the Communication Device to your login 

account. 

 

Call the Trainer if you have any questions, and when you're done. 
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2.2  MODULE 2.2: Testing Communication Tools  

 

 
Step 1: Navigate to Tools -> Communication Monitor  
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Step 2: Tick on Select from list and click Open button  
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Step 3: Select the meter you want to interrogate (read) and then click Select 

button  
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• Check the relevant checkbox (e.g. Phasor, Total, Profile or 

Events), and Click on the Start Read button 

• You should now see the actual conversation between the 

server and meter on your web page 

• The Cyan is what the Server is saying to the meter, and the 

Green is what the meter is replying. 

• Any other actions as part of the Reading Attempt, including 

success or error report messages are displayed in White. 

 

It is generally more efficient for the installer to leave the site only after 

the communication link has been verified. 
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2.2.1 Exercise 2.2: Module 2 

Using the Communication Monitor, read the Phasor of the meter, if 

applicable. 

Report to the lecturer the Red Voltage you've read with the 

timestamp (View->Phasor Graphs). If you cannot read the meter, 

troubleshoot the error report at the end until the reading succeeds. 

 

 

Call the Trainer if you have any questions, or and when you're 

done. 
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2.3  MODULE 2.3: Commissioning - Edit Meter Details 

 
Step 1: Go to Edit menu and select Meter Details 
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Step 2: Tick on Select from list and click Open button  
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Step 3: Select the meter you want to Edit and then click Select button 
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• CT and VT ratios kept in Zimele MDMS are not read from the meter or 

written to the meter, and only used for validating data, and display 

purposes 

• The only multiplier applied by Zimele MDMS is usually the Pulse 

Multiplier: it will take the quantity coming from the meter and multiply it 

by the fraction specified in this screen 

• If you want to limit your fault reporting to 'commissioned' meters only, 

check the commissioned flag for every meter that has been verified as 

correct, and it will start appearing on the problem meter list 

• The System will not call in any profile data for a meter before the 'Last 

Read Up to Date & Time'. If you want to re-read any profile data from 

the meter, set this date back 
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• The System will not call in any data from before the 'Installation Date & 

Time'. If your meter has a history of a couple of months that you want to 

read in, set the installation date back to whenever you need the data 

from. Remember to set the 'Last Read Up to Date & Time' back to the 

same date 

 

• If you change the Pulse Ratio it will not immediately change the profile 

already in the system. To apply your new multiplier, the easiest is to call 

it in again: set the 'Installation Date & Time' back and read it in. 

Alternatively, use Tools->Modify Readings, or Tools->Import Readings 
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• If you want to stop manual and automatic reading of the 

meter, check 'Disabled' 
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• If you are replacing the meter, click on 'replace meter': all the 

metering point data like the CT and VT ratios will be kept for the 

new meter 

 

 

 
 

 
• If you are replacing a communications device, use Tools -> 

Replace Communications Device 
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• If you are replacing a SIM card, Use the replace checkbox on 

Edit->SIM 
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• If you want to remove a meter, it is generally not a good idea to 

remove it completely, since your old data would then also be 

lost (and it would still be historically applicable to a meter 

account). Rather choose 'uninstall meter' on this screen, which 

will keep the meter but disable it. If a meter has been 

uninstalled like this, it can be re-installed elsewhere by adding 

the meter to the system again. This will not cause a clash, and 

the old and new instance of the meter will co-exist peacefully 
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2.3.1 Exercise2.3: Module 2 

By setting back your meter's Installation and Last-Read-Up-to dates and 

calling in the Meter Totals manually on the: Tools->Communication 

Monitor, find out what is the oldest totals it has available in memory, if 

any.  

 

You can view the totals read from a meter at  

Edit->Meter Totals.  

The totals read from the meter will have '3' as the least significant 

decimal digit in the Status. 

 

Call the Trainer if you have any questions, and when you're done. 
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3 MODULE 3:  COURSE 160 ENGINEER ROLE: METER DATA 

UNIFICATION AND SYNCHRONISATION SAP TO ZIMELE 

MDUS INTERFACE 

 

Recommendation: 

• You should have experience with SAP (https://go.sap.com/) 

• It would be beneficial to have experience of SAP for Utilities (IS-U) 

• You should have done the AMI training with SAP 

3.1  

Gives you the power to: 

 Read real meters from within the SAP user interface in real time using 

Zimele MDMS e.g. close out readings 

 Validate readings before sending to SAP 

 Route user and meter generated events from meters to SAP workflow 

 Can correctly summate maximum demand readings 

 Automatically populate billing multipliers and location information from 

SAP to Zimele MDMS 

 Remote disconnection and reconnection of meters 

 Sending a text to a meter in the field 

 Once you are done with this course, you should be able to: 

 Add MDUS entity 

 Set up MDMS entity SOAP connection to SAP in both directions 

 Set up MDMS Events 

 Set up Summated Maximum Demand relationships for SAP billing 

 

  

https://go.sap.com/
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3.2  How to add an MDMS entity on Zimele MDUS 

 
Prerequisite: 

Adding MDMS entity is a three-stage process: 

 

First 

You need to buy and commission a SAP IS-U EHP4 (e.g. 

https://wiki.scn.sap.com/wiki/display/ESpackages/SAP+enhancement+pack

age+4+for+SAP+ERP+6.0), and specifically the AMI interfaces  

(e.g.https://wiki.scn.sap.com/wiki/display/ESpackages/Advanced+Metering+

Infrastructure). You will need consultants to help you with that. 

 

Second 

You need WSDL files for the end points that Zimele MDMS will consume to call 

back into SAP with new readings and events as they become available. 

These Web Services must of course be addressable from the Zimele MDMS 

server. 

 

Third 

You need the Sender Business System ID, Recipient Business System ID, 

Advanced Metering System ID and the IP of the SAP Server that offers the 

SOAP services. 

 

  

https://wiki.scn.sap.com/wiki/display/ESpackages/SAP+enhancement+package+4+for+SAP+ERP+6.0)
https://wiki.scn.sap.com/wiki/display/ESpackages/SAP+enhancement+package+4+for+SAP+ERP+6.0)
https://wiki.scn.sap.com/wiki/display/ESpackages/Advanced+Metering+Infrastructure
https://wiki.scn.sap.com/wiki/display/ESpackages/Advanced+Metering+Infrastructure


 

Proprietary & Confidential   |   Page 73 

 

3.1.1  Log in 
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3.1.2 Go to the overview screen (Home) 
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3.1.3 Click on the add new button   
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3.1.4 Select servers 
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3.1.5 Select SAP MDUS 
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3.1.6 Enter the following 

 

i) Sender business system ID 

ii) Recipient business system ID 

iii) Advanced metering system ID, and  

iv) IP address of the SAP PI Server  

v) Click on the Finish button  
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3.1.7 The SAP MDUS Entity should now exist. 
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3.1.8 HOW to configure the SOAP endpoints on the MDMS 

 

There will be an exchange of SOAP files between you and the SAP 

administrative staff, to allow Zimele MDMS to call SAP over SOAP, and to 

allow SAP to call Zimele MDMS over SOAP. 

 

Give the URL to the Zimele MDMS SOAP services to your SAP administrative 

staff, so that they can download the WSDL files they need. 

For example, https://zimeletech.pnpscada.com/soap  

 

To see for which WSDL files you must ask from them, and the place to 

configure them. 

 

  

https://zimeletech.pnpscada.com/soap
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3.1.9 Log in  
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3.1.10  Go to the overview screen (Home) 
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3.1.11 Select tools > Setup MDUS 
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 On the drop-down list press on the Open button    

 
 

 All the interfaces that MDUS can call back into SAP are displayed 

 Select SAP MDUS: COJ and press Select button  
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3.1.12 The Sender and Recipient System ID’s, and the AMS ID  
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3.1.13 Specifically choose HTTP 
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3.1.14 Specify the IP address of the SAP PI server where MDUS will 

connect to 
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3.1.15  The special port that they opened for you, possible HTTP security 

parameters 
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3.1.16  Leave “Is Head-End for Server” and “Scale Readings blank  
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3.1.17 The “Hold back suspect readings until validated” setting will stop 

unvalidated readings to go through to SAP if set 

 

 
 

When you’re done updating the parameters, press the Submit button 

 to save your changes 
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3.1.18  When you have the WSDL files, upload them one at a time on the 

screen below. 

 

 

 
 Ask the SAP consultant for all the WSDL files, and load them one per line 

on the drop list, or  

 Ask for the specific ones that your SAP consultant advises you to use 

 Press on the choose file button  and select the WSDL you 

want to configure 

 Press the Configure New Function button 

 When all of this is done, your SOAP connection is configured. 

 

You can download the original file you uploaded, as well as the changed file 

that was changed to reflect the IP and port of your PI/PO server. It is the 

changed file that will be used by MDMS to call the functions. You can also 

delete a Function. 
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HOW to configure MDUS Events 

 

3.2 Log in 

 

 
 

 

 
3.2.1  Go to the overview screen (Home) 
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3.3 Select Tools > Setup MDUS Events 
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i) On this screen, enable the events that you want to take to SAP 

ii) You should also specify the SAP TypeCode, SAP CategoryCode and 

SAP Value ID per event that would make sense 

 

 
To know what makes sense for the way that your SAP has been configured, 

ask your SAP consultants. 

 

An example of a typical WSDL file that should be implemented on your SAP 

server, for Zimele MDMS to call back, has been posted on a link at the 

bottom of this page, because that is not part of EHP4, but a customized 

interface. 
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3.4.  How to set up Maximum Demand (MD) Summation 

3.4.1 Log in 
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3.4.2 Go to the overview screen (Home) 
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3.4.3  Select Edit > Advanced Meter Settings 
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3.4.4  Tick on the select from list and then press the Open button 
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3.4.5  Select Meter number 13106616 and then press select button 
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Near the bottom of the screen is a field called “SAP co-incident MD ID”.  

If you enter a value in here, all meters with the same value entered will return 

their pro-rata part of a summated MD across all the meters. 
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4 MODULE 4: COURSE 161 ENGINEER ROLE: MDMS 

TROUBLESHOOTING 

 

Prerequisite 

• Course 160 

• Experience with SAP (https://go.sap.com/)  

• Experience with AMR 

4.1  

Helps you with: 

• Knowing how to analyze the SOAP logs 

• Knowing how to analyze the Meter Read Requests 

• Understanding and troubleshooting the Meter Model as mirrored from 

SAP to MDMS 

• Understand when Meter Reading Requests are honored 

4.2  

Once you are done with this Course, you should be able to: 

• Check why a meter reading is not updating to SAP 

• Check if a Meter definition exists properly on MDMS 

• Check if a Meter multiplier and data is consistent 

• Resend a Meter Reading to SAP 

• Resend SAP Message to MDMS 

• Create Virtual MDMS reading 

 

  

https://go.sap.com/
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4.3  HOW to analyze SOAP logs 

 
4.3.1 General SOAP mode 

 

All SOAP between SAP and MDUS, in both directions, is in the form of 

Messages that are sent. There are no RPC kind of SOAP, where the same 

SOAP message waits for a reply from the implemented function on the server. 

This makes the SOAP a lot more robust. The SOAP messages can be 

envisaged as a single XML structure, which is essentially a single nested 

structure of values. 

4.4  

How to choose message logs to view 

 

Log in 
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Go to the Overview Screen (Home) 
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Select View > MDUS log 

 

 

Tick on the select from list and then press the Open button   
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The above screen dump shows a Selection Screen, where you can choose 

which messages to see by using the following: 

• The Start and End Date & Time is self-explanatory and should be 

entered in the SQL format YYYY-MM-DD hh:mm:ss 

• The MDMS Msg ID is a number unique per message per Zimele MDMS 

server over all MDMS entities on that server. A comma separated list 

may be specified. 

• The UUID is essentially a GUID (unique in the universe) assigned in SAP 

per message 

• The Reference UUID is typically set for messages that is sent as a Reply 

or an Acknowledgement on another message. It would then contain 

the UUID of the original message 
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• The Function is the specific function called by SAP or MDMS – easiest 

way to know what to select here is to first select a lot of messages and 

then take the specific one you want from the column in the report. This 

loosely corresponds to the drop list of functions in the MDMS Edit screen 

• Detail is the value of any field in the message. If any of the values 

match this value, the message would be selected 
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• Result Message is whether it was successful or whether there was some 

error. The easiest is also to run the report first for all values, and then 

specify the value as seen in the appropriate column for the specific 

kind of row required 

• Double UUIDs can happen, for example in cases where you retry the 

same message from SAP to MDMS. If you want to avoid showing the 

same retried message twice or more times, you should check 'Do not 

list Double UUIDs' 

• When you have entered which messages you want to see, press the 

Submit button  to see the report 

• This is the log of all XML messages sent between SAP and MDMS 

• SAP will for instance send messages to 'create' meters, and to 'create' 

registers to read, and to create meter reading requests 

•  MDMS will for instance send messages back to send readings for 

previous meter reading requests that was created from SAP 

4.5   
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MDMS Log Report view 

Here is shown the messages that was sent and received, one line per 

message, with various general fields.  

You can resent ALL the messages listed to MDMS as though it was just sent 

from SAP, by clicking the link at the bottom of the report. Of course, that 

would only apply to messages where the DIRECTION column's value is 'SAP-

>MDMS' 

This can sometimes be handy if Meter Entities was not properly created, or 

meter register formats not properly created, or meter readings not properly 

created, for some reason. However, it should not be necessary under normal 

circumstances. 
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MDMS Log Detail view 

 

You can view message details by clicking the value under the UUID column 

heading. 

Here is shown all the Detail fields of the XML message, with the nested field 

name, and the value that was specified. You can click the 'resend to myself' 

link to re-submit the message to MDMS as though it was just sent from SAP.  
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4.2  How to analyze Meter Read Requests 

 

4.2.1 General Read Method 

When SAP wants to read a meter register, it creates a Meter Reading 

document through one or more messages, which are recorded in a Meter 

Readings table in MDMS. Typically, there would be multiple registers read per 

meter per date. Each one is a separate Meter Reading Document. 

When a meter is read in, MDMS will check against the existing but 

outstanding Meter Reading Documents to see if there is any that can be 

honoured, and if there is, it will send Messages of its own to SAP to report the 

register reading. 

  

 4.2.2 How to choose readings to view 

 

Log in 
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Go to the Overview Screen (Home) 
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Select View > MDUS reading docs 

 

 
 

 On the drop-down list press on the open button    
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 All the interfaces that MDMS can call back into SAP are displayed 

 Select SAP MDUS: COJ and press Select button  
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This is a Selection Screen, where you can choose which reading 

documents to see: 

 

• The Start and End Date & Time is self-explanatory and should be 

entered in the SQL format YYYY-MM-DD hh:mm:ss 

• The Meter Serial Number is the number of the meter, or the SAP device 

ID, of the meter read 

• The Reading Document Number is the unique number assigned by SAP 

to a meter reading doc. 

• The checkboxes are self-explanatory 

• When you have entered which messages you want to see, press the 

Submit button to see the report 

• There is also a link at the bottom of the selection screen, to download a 

spreadsheet of all the defined MDMS meters, with their SAP device ID’s. 
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Meter reading document report 

This is a table view, with one row per Meter Reading Document, of all the 

readings that SAP has requested that satisfies the Selection Criteria. 

 

When a value is read, the SAP Value column gets filled in, and the Date 

Fulfilled column. SAP is then supposed to Acknowledge receipt of this 

reading. If MDMS has tried 5 times to send a value, it will give up. If you want 

MDMS to try again, select 'rollback update'. 
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4.6  How to see why Meter Readings are not updating 

Did SAP ask for the reading from MDMS? 

Sometimes it happens that a meter has not been correctly configured as an 

AMI meter in SAP, and SAP doesn't even ask MDMS for a reading. 

Therefore, go to the Meter Reading doc report and search for the Meter 

Reading document number as it exists in SAP. If you do not find it, MDMS 

doesn't know about it, and the meter has probably been created as a non-

AMI meter. This is why your readings are not automatically updated. 

You can also search for the Meter Reading document number in the MDMS 

log as a Detail value field. It is possible that MDMS for some reason did not 

mark the reading, so if you find it in the log   but not the reading docs, you 

can try to resend the message to MDMS. 

However, if you also can't find it in the log, and the SAP consultants swear the 

readings were created ok, perhaps the PI guys can resend the messages? 

MDMS cannot fabricate the reading documents from scratch, it needs the 

messages to be sent from SAP, and if it has no record of them, they need to 

be resent. 

  

Did SAP 'create' the MDMS meter record (associating the SAP device ID with 

the actual entity on Zimele MDMS)? 

When you download the spreadsheet on the Meter Reading docs selection 

screen, the Meter will not be listed there if SAP did not create the Smart meter 

record in MDMS by sending it the appropriate messages. If you download the 

csv and it is not there, this is why your readings are not updating. 
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Did SAP create the appropriate Registers on the MDMS meter record?  

If the row in the csv downloaded in step 2 has a 0 in the last column, no 

registers has been defined by SAP for this meter. That is why the readings are 

not updated. 

If, on the Meter Reading Document report, the SAP Register column is a long 

number with a lot of zeroes in front, instead of an intelligible register 

description, SAP has not defined the same registers for this meter than it has 

asked for in the reading document. That is why the readings are not 

updated.  (The long number is the unique register ID in SAP, and for 

resolvable registers, you can see the long number as a tool tip if you hover 

your pointer over the register descriptor)  

If the appropriate registers do not exist, MDMS cannot fabricate them. 

Those messages that creates the registers needs to be resent to MDMS. 

  

Does the meter entity exist on MDMS? 

Try to select the meter entity in the Overview screen. Sometimes, a 13-digit 

number would map to an 8-digit number, e.g. 3201550644737 is the same 

meter as 55064473. If you can't find the meter, it has not been created in 

Zimele MDMS yet (typically done by the Technician), and that is why you're 

not getting a reading. 

  

If you do find it, has the meter been read in? 

If you do find it, but it is red in Overview when you select it, the meter has 

never called in. That is why you're not getting a reading. 

Go to the Edit -> Meter Details of the meter. If the MAXDATE (last read up to 

date) of the meter is less than the 'Date asked for' on the meter reading doc 

report, the reading does not update because the meter has not been called 

in. 

If the meter is called in, but still does not update, it might be that the profile is 

read in but there is no TOU register readings for the meter on a half hour 
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boundary yet. Go Edit? TOU Billing Register Values. If there are no values 

listed, that is why your readings does not update. 

You probably need to read the meter after a Bill Reset event on the meter, 

before the readings would be sent through. 

(In some cases, where the reading does   not advance at all, zero values can 

be put in as initial values. Other algorithms might also slow this down in future, 

e.g. on season change, but that is still to be determined) 

  

4.7  

 

It is possible that you have enabled the Validation sub-system on your MDMS 

entity, and that the meter has been invalidated.  

If you go to the Meter Validation screen and find your Meter there, with an 

invalid from date of before the reading date, that would be why your meter 

is not updating. Fix the fault on the meter or meter data and then Validate 

the meter. After that, on subsequent reads, the readings should go through. 
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4.8  How to see why Meter Readings are wrong 

 

Sometimes you will get queries about some of the readings, that it looks 

wrong, for various reasons e.g. that the reading went in reverse, or that the 

reading is too high. 

 

When this happens, the first step is always to view your Meter Event Log for 

the month surrounding the reading and see if there were any Audit events. 

There would usually be some events at the time of the wrong reading that 

should have alerted you to the wrong data. 

 

If you use the Validation sub system of Zimele MDMS, you can set such events 

to Invalidate data on a meter, and in the MDMS edit screen, you can set the 

MDMS not to return such values. 

 

However, if this is not the case, go to your Profile Graph adjoining the 

reading, and see if you can see any obvious disruptions to the normal usage 

pattern. 

Although the full scope of troubleshooting the underlying problem is beyond 

the scope of this course, some examples of problems are that it could be that 

a VT fuse has blown, or that there was some other thing on site that went 

wrong. In some rare cases there might even have been a data corruption 

due to communication corruption, or the Billing ratio might also have been 

applied wrong: usually in such a case, if the bad data is younger than 3 

months, you can 'fix' the data by setting the MAXDATE back to before the 

problem and reading in the meter again. 

 

If that doesn't work, you'll have to fix the data manually or call for a technical 

support for Zimele MDMS support. 

  



 

Proprietary & Confidential   |   Page 123 

However, if the data looks right, and the reading sent to SAP is still wrong, you 

can try to do a Virtual MDMS Reading (Tools -> Create Virtual MDMS 

Reading) This is not to be confused with a normal Status 9 reading that is 

initiated from SAP side. It is a reading initiated on MDMS side, and it will create 

the meter reading document on MDMS side, as though SAP requested it, so 

that you can go and look at it and attempt to find the point at which the 

problem occurs. 

 
If the SAP Value for the virtual reading is correct, then the problem must have 

happened somewhere beyond Zimele MDMS. However, if the SAP Value in 

the Meter Read log of the Virtual Reading is also wrong, then the problem still 

exists on Zimele MDMS. 

This functionality can also be used as a 'dry run', after data was fixed, to 

make sure the readings to SAP will go through fine if they are re-issued. 
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